티스토리 뷰

node.js를 이미 설치한 상태에서 간단한 gulp 예제를 실행해보려고 했다.

npm install gulp --global

gulp -v



gulp 설치 후 버전 확인을 하려고 하면 아래와 같은 에러가 발생했다.

module.exports = (arr, ...values) = > {            ^

SyntaxError: Unexpected token .

at Module._compile (module.js:469:25)

at Object.Module._extensions..js (module.js:474:10)

(이하 스샷 참조)





뭐가 문제인지 몰라서 한 참을 삽질 했는데, 위에 로그를 보니 뭔가 노드 버전이 안 맞아서 생긴 오류 같았다.





노드 버전을 확인해 보니 v0.10.13였다. 도대체 왜 이 버전을 쓰고 있었던 거지?

윈도우 노드 업데이트 하는 방법들을 찾아 보긴 했지만 결국 사이트에 가서 msi를 다운 받아 기존 버전을 삭제하고 재설치 했다.

업데이트 후 버전을 확인하니 v.4.4.7






다시 gulp를 설치하고 버전 확인을 하니 제대로 동작한다!





헬로월드 한 번 보기 참 힘들다.

드디어 성공!









저작자 표시 비영리 변경 금지
신고
댓글
댓글쓰기 폼
«   2017/09   »
          1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
글 보관함
Total
90,779
Today
9
Yesterday
151